Error on fresh Install

Issues when installing or upgrading AlegroCart
Post Reply
StenTheMan
Posts: 2
Joined: Fri Jan 29, 2010 2:06 pm

Error on fresh Install

Post by StenTheMan » Fri Jan 29, 2010 2:13 pm

Hello AlegroCart Team,

I've installed AlegroCart on my computer. I'm using the latest Wampserver. Everything including the installation steps were no problem but when I accessed the front page and admin panel, it says somthing below with a long funny characters afterwards:

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\shop\alegro\index.php on line 17

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\shop\alegro\library\locator.php on line 77


What could have gone wrong? Your soonest assist would be very much appreciated.

Thx

User avatar
Brent
Site Admin
Posts: 4398
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Re: Error on fresh Install

Post by Brent » Fri Jan 29, 2010 5:06 pm

It has to do with the PHP 5.3.1 . It does not allow assignment of new class by reference.
The are three new files in the attached zip.
index.php
admin/index.php
library/locator.php

Upload these to replace the existing files.
I will be testing myself as soon as I can get up an alternate server with PHP5.3 on it.

Just set up 5.3 environment and the deletion of the call by reference fixed the problem.
The three files in the zip below will correct it.

Also see PHP 5.3 notes
Attachments
Upload.zip
(3.18 KiB) Downloaded 501 times

StenTheMan
Posts: 2
Joined: Fri Jan 29, 2010 2:06 pm

Re: Error on fresh Install

Post by StenTheMan » Sat Jan 30, 2010 12:17 am

Thanks ... It's now working :-)
I'll play around and give feedbacks to you later

Again thx...

devamfl
Posts: 1
Joined: Tue Feb 16, 2010 8:13 pm

Re: Error on fresh Install

Post by devamfl » Tue Feb 16, 2010 8:16 pm

I uploaded v1.2 but install gives internal error 500

What is the problem?

I have it working now, I was running the install from the root duh

I really like this script. Is there a manual available and is it possible to enable captcha support?
Last edited by devamfl on Fri Feb 26, 2010 7:46 am, edited 1 time in total.

User avatar
Brent
Site Admin
Posts: 4398
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Re: Error on fresh Install

Post by Brent » Tue Feb 16, 2010 9:33 pm

This is general web server error. It does not return specifics.
You need to discuss with your web host. Probably something is configured incorrectly on the server.

Leonadis
Posts: 3
Joined: Mon Jul 19, 2010 10:01 pm

Re: Error on fresh Install

Post by Leonadis » Tue Jul 20, 2010 3:01 pm

Hi Guy's, I have installed the cart and uploaded everything to the servers. I can't see it at all when I open my site up, there are no "uninstalled" styles.
I have checked the files on the server and re uploaded them just to be sure but can't access the files from the control panel (phpBB defaults only are showing).
It is probably something simple, I am new to phpBB so it"s a bit different and I'm still learning it.
Any ideas you have would be greatly appreciated, every thing seems to be ok on the server and all software is up to date and the right releases, both on the server and on my computer.
I can't see any thing other than the default programs and styles so have not been able to run the "install" part....
Thanks

Leo.

User avatar
leo
admin
Posts: 4248
Joined: Sun Dec 13, 2009 8:27 am
Location: Hungary

Re: Error on fresh Install

Post by leo » Sat Jul 24, 2010 12:23 pm

Leonadis wrote:Hi Guy's, I have installed the cart and uploaded everything to the servers.

Have you installed the cart locally and uploaded the "results" to your server?
Try this:
1. download the cart from

Code: Select all

http://forum.alegrocart.com/viewtopic.php?f=8&t=152

2. unzip the file
3. under AlegroCart_1.2.3beta you will have 2 directories: install instructions and upload
4. change to the upload directory and copy all the entire contents to your server (even the hidden file!)
Have a look at Install.doc as well.
Hope this helps.
Leo

Post Reply