Page 1 of 1

Testing with php 5.3 with WAMP & XAMPP Servers

PostPosted: Tue Mar 23, 2010 7:45 am
by Brent
I would suggest you turn off the error reporting E_DEPRECATED.

I am working to find any depreciated functions, most notably regex functions.
As there are probably no productions servers running 5.3, this will not be a problem.
The AlegroCart Demo works fine on a productions server.

In php.ini, find the following line, about line 514. comment out with semi-colon ;
Code: Select all
;error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED


add this line below
Code: Select all
error_reporting = E_ALL & ~E_NOTICE

This turns off the deprecated notice for now.

You can also replace
Code: Select all
error_reporting(E_ALL);

in index.php and admin/index.php with:
Code: Select all
if (phpversion() >= '5.3'){
error_reporting(E_ALL ^ E_DEPRECATED);
} else {
error_reporting(E_ALL);
}

That will achieve the same results.

Re: Testing with php 5.3 with WAMP & XAMPP Servers

PostPosted: Sun May 13, 2012 3:07 am
by tomsawyer
Nice post & i get so much important information :-)

Re: Testing with php 5.3 with WAMP & XAMPP Servers

PostPosted: Fri Jan 18, 2013 7:06 am
by Bluesplayer
I am actually running my shop on a home server setup - Ubuntu Server.

Home servers are the dogs b******* as far as I am concerned. With the power of home broadband now you can save a fortune on hosting fees.