AlegroCart open source E-commerce
Web hosting by Host1Plus

New installs (Requirements, Directory and file layout)

knowledge base and frequently asked questions

New installs (Requirements, Directory and file layout)

Postby Brent » Thu Apr 08, 2010 9:20 am

System requirements:
PHP Version 5.0 or greater is required.
MySQL extension must be enabled in php.ini
GD extension must be enabled in php.ini
File_uploads must be enabled in php.ini
zlib must be enabled in php.ini
Session.auto_start must be 0 (disabled in php.ini

In Apache httpd.conf DirectoryIndex index.php (index.php must be specified as a default start-up file name)

Make sure the following folders and files are writable. For Linux/Unix use the following:
chmod a+w image/
chmod a+w image/cache/
chmod a+w image/flash/
chmod a+w cache/
chmod a+w download/
chmod a+w config.php

This is the basic directory and file layout you need to achieve when uploading your files and folders.

Image
User avatar
Brent
Site Admin
 
Posts: 4239
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Return to FAQ / Layouts / Knowledge Base

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 2 guests

cron