Report Bugs for Version 1.2.9 here

Enter AlegroCart Bugs Here, but if you're not certain, post in General support first.
Post Reply
User avatar
Brent
Site Admin
Posts: 4419
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Report Bugs for Version 1.2.9 here

Post by Brent » Fri Nov 20, 2015 11:03 am

Bug report thread for 1.2.9

gob33
Posts: 107
Joined: Wed Apr 07, 2010 3:10 pm

Re: Report Bugs for Version 1.2.9 here

Post by gob33 » Fri Nov 20, 2015 4:02 pm

At install, i have, for a DB user with no password (test DB):

Code: Select all

Notice: Undefined index: db_pass in D:\Wamp\www\ALEGROCART-1.2.9\upload\install\step3.php on line 177

User avatar
leo
admin
Posts: 4263
Joined: Sun Dec 13, 2009 8:27 am
Location: Hungary

Re: Report Bugs for Version 1.2.9 here

Post by leo » Thu Dec 03, 2015 7:04 am

Thanks. Fixed.

gob33
Posts: 107
Joined: Wed Apr 07, 2010 3:10 pm

Re: Report Bugs for Version 1.2.9 here

Post by gob33 » Sat Dec 05, 2015 3:01 pm

If you try to add one of the motorbike items from the demo inside your cart, animation is done but the cart always stay empty. Strange ? Is there a special option somewhere ?

User avatar
leo
admin
Posts: 4263
Joined: Sun Dec 13, 2009 8:27 am
Location: Hungary

Re: Report Bugs for Version 1.2.9 here

Post by leo » Sun Dec 06, 2015 1:22 am

Fresh install or update?
The mini-cart is affected or the cart? Or both?
Have you faced this issue in every template (1,1.2,2.1,3)?
Try to re-save the affected motorbike in admin.

gob33
Posts: 107
Joined: Wed Apr 07, 2010 3:10 pm

Re: Report Bugs for Version 1.2.9 here

Post by gob33 » Tue Dec 08, 2015 7:45 am

Fresh install, cart and minicart.
All motorbikes with options cant be added to cart. Try it.

User avatar
Brent
Site Admin
Posts: 4419
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Re: Report Bugs for Version 1.2.9 here

Post by Brent » Wed Dec 09, 2015 4:21 pm

All you need to do is open up the products in admin and then save.
Because the products were created before the new product option system, there are no entries in product option.
Just saving the existing product will create all the required entries in product option that are required.
This is only an issue with the few products in the cart that have options.
When someone creates new products, these entries are done automatically when the product is saved.

kelee15
Posts: 2
Joined: Thu Sep 15, 2016 11:44 am

Report a Bugs Undefined variable: category_menu

Post by kelee15 » Thu Sep 15, 2016 11:50 am

Notice: Undefined variable: category_menu in C:\xampp\htdocs\ale\catalog\template\default\layout.tpl on line 51

kelee15
Posts: 2
Joined: Thu Sep 15, 2016 11:44 am

Re: Report a Bugs Undefined variable: category_menu

Post by kelee15 » Thu Sep 15, 2016 11:59 am

kelee15 wrote:Notice: Undefined variable: category_menu in C:\xampp\htdocs\ale\catalog\template\default\layout.tpl on line 51
CHANGED THE VARIABLE TO $category, THEN THE BUG WAS GONE.

User avatar
leo
admin
Posts: 4263
Joined: Sun Dec 13, 2009 8:27 am
Location: Hungary

Re: Report Bugs for Version 1.2.9 here

Post by leo » Thu Sep 15, 2016 11:09 pm

The line 51 in the layout.tpl file must be

Code: Select all

<?php if($category_menu){?>
Do not change it to $category.
Have you modified the header with the template manager?

Post Reply