AlegroCart open source E-commerce
Web hosting by Host1Plus

Controller not properly loading in admin

Support for coding, modules or other software issues

Controller not properly loading in admin

Postby fretbeater » Thu Dec 08, 2011 5:55 am

Everytime i bring up report online in admin I get this line repeated about 10 times..

Notice: Undefined offset: 1 in /home/robert0/public_html/admin/controller/report_online.php on line 26


what can i do to get rid of this notice?
fretbeater
 
Posts: 8
Joined: Fri Dec 02, 2011 5:08 am

Re: Controller not properly loading in admin

Postby Brent » Thu Dec 08, 2011 6:09 am

In admin/server info, check for Suhosin installed.
This disrupts sessions and encypts the session variables.
The session data will not be availabe when Suhosin is installed.
Session Data - You may find Report on Line does not return all the data you expect. This may be caused by Suhosin security mod for PHP. You will have to get the host to disable this to correct or install a standard PHPini file.
User avatar
Brent
Site Admin
 
Posts: 4365
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Re: Controller not properly loading in admin

Postby Brent » Sun Dec 11, 2011 5:37 pm

Try this. It contains a new session class and a new report online controller.
The sessions are now class dependent instead of using php sessions.
The report online is modified to use proper serialization.
You should delete any existing sessions as these will create errors due to incompatibility with the new session values.
Let me know if this fixes your problem.
Attachments
Sessions.zip
(3.95 KiB) Downloaded 284 times
User avatar
Brent
Site Admin
 
Posts: 4365
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh


Return to Coding Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron