Permissions - for a non-techie

Issues when installing or upgrading AlegroCart
Post Reply
User avatar
cmebd
Posts: 31
Joined: Sun Jul 04, 2010 3:47 pm

Permissions - for a non-techie

Post by cmebd » Sun Jul 04, 2010 5:59 pm

Hi There,

Not being a techie or having shell access can you please explain, in simple terms (numeric) what permissions I need for config.php & admin/config.php.

Thanks
Be nice to the people you meet on the way up! They may be the ones holding the net when you're on your way down (don't know who first said that).

User avatar
Brent
Site Admin
Posts: 4419
Joined: Sat Dec 12, 2009 3:35 pm
Location: Canada eh

Re: Permissions - for a non-techie

Post by Brent » Mon Jul 05, 2010 8:50 am

Change to 644 if it is not already that.

User avatar
cmebd
Posts: 31
Joined: Sun Jul 04, 2010 3:47 pm

Re: Permissions - for a non-techie

Post by cmebd » Mon Jul 05, 2010 2:45 pm

Thanks Brent
Be nice to the people you meet on the way up! They may be the ones holding the net when you're on your way down (don't know who first said that).

ds_robert
Posts: 41
Joined: Fri Mar 01, 2013 5:26 am

Re: Permissions - for a non-techie

Post by ds_robert » Fri Mar 01, 2013 5:34 am

I have just installed version 1.2.8 via cPanel with Softaculous.

I am logging in to the Administration panel and it displays:
Warning: Make the config.php unwritable!
Warning: Make the .htaccess unwritable!

.htaccess has permissions set to 0644
config.php in the top level directory has permissions set to 0644
config.php in the admin directory has permissions set to 0644

Can anyone tell me the required settings to resolve these warning messages?

Thanks.

User avatar
leo
admin
Posts: 4263
Joined: Sun Dec 13, 2009 8:27 am
Location: Hungary

Re: Permissions - for a non-techie

Post by leo » Fri Mar 01, 2013 5:55 am

Normally if the permission is set to 644 the warning message should disappear.
I suppose you have used the auto installer that cannot handle the permissions correctly. I suggest you to install AC via ftp (e.g with Filezilla). That will solve the issue.

ds_robert
Posts: 41
Joined: Fri Mar 01, 2013 5:26 am

Re: Permissions - for a non-techie

Post by ds_robert » Fri Mar 01, 2013 6:04 am

Many thanks Leo, done and problem resolved.

Post Reply